Latency continues to be within expected parameters.
The issue has been resolved
Posted Nov 01, 2025 - 06:56 CET
Monitoring
With the source of the problem rectified and the affected service having completed the recovery, we have re-enabled product pictures everywhere.
Overall shared FS latency is back to expected parameters.
We are keeping a close eye on the latency to make sure the applied correction remains effective.
Posted Nov 01, 2025 - 06:29 CET
Update
With the pictures still disabled for most sites, requests are being served quickly.
The underlying root-cause of the problem has been identified and rectified. However, processes need some time to recover from the failure. We will keep pictures disabled on most sites until the affected service has fully recovered.
Posted Nov 01, 2025 - 06:20 CET
Update
The investigation into the file system performance is ongoing.
In the mean time we have disabled product pictures platform-wide in order to reduce the dependence on the shared file system for regular site access by clients.
Posted Nov 01, 2025 - 05:42 CET
Identified
We are investigating an on-going issue with backend shared storage causing some web requests to be very slow to be responded to.
Posted Nov 01, 2025 - 05:29 CET
This incident affected: eCommerce Platforms and Data interfaces.